WordPress Россия

Плагин "WP-NoIE6" выводит заглушку при открытии сайта в IE6

Добавлено 23 апреля 2010 в категорию Плагины.

Увидел вчера на Хабре топик про страницу-заглушку для обладателей устаревшего браузера IE6. И сделал из этой страницы полноценный плагин для WordPress. Никакого давления на посетителя с устаревшим браузером – страница-заглушка показывается лишь один раз (вешается кука на одну неделю), затем посетитель может продолжить просмотр блога дальше. Из огромного количества подобных плагинов этот выделяется лишь одним – встроенная в плагин страница-заглушка выглядит очень красиво и современно, других приемлемых вариантов я не встречал. Авторы оригинальной страницы – avr и mdss. По-настоящему протестировать плагин мне не удалось, все-таки установить на рабочую систему IE6 невозможно, но замена в виде средства тестирования IETester (позволяет просматривать сайт в  четырех разных версиях IE) показала, что плагин справляется идеально и никаких нареканий в его работе не возникает.

Скачиваем плагин по ссылке внизу этой страницы и устанавливаем его:

1. Распаковываем архив.

2. Копируем папку wp-noie6 в /wp-content/plugins/.

3. Заходим в админку блога на вкладку "Плагины" и активируем плагин.

Собственно, вот и все. Плагин уже работает и уже показывает заглушку для посетителей с IE6. Никаких настроек в плагине нет, но кое-что вы можете изменить через правку кода плагина. Если вы хотите повесить куку не на неделю, а на год, то вы должны изменить в файле wp-noie6.php строчку:

20
setcookie("ie", "yes", time()+60*60*24*7, "/");

на

20
setcookie("ie", "yes", time()+60*60*24*360, "/");

Также иногда бывает необходимость вообще запретить доступ на сайт посетителям с устаревшим браузером (например, когда дизайн сайта некорректно отображается в IE6), чтобы это реализовать вы должны изменить строку:

18
if ($show != "yes")

на

18
if ($show != "no")

Отредактировать шаблон выводимой страницы вы можете в файле template.php в папке плагина. Это все, удачи.

 

Автор плагина: Flector

Скачать плагин: wp-noie6.zip

Рассматриваемая версия: 1.00 от 26.01.2010

Совместимость с версией WordPress: 2.3 и выше.

Категории